Supported iOS models

Jan 4, 2019

We recommend updating your device to iOS 11.0 and above to download the latest Hulu app — complete with access to new features and all of the content that you subscribe to.

In order to run iOS 11, you will need one of the following devices:

  • iPhone 5S or later
  • iPad 5th generation or later (iPad Air, iPad Air 2, iPad Pro, and iPad mini 2, 3 and 4)
  • iPod Touch 6th generation

Not sure?

Refer to Apple’s site if you need help identifying which model iPhoneiPad, or iPod Touch you own. If you have any trouble downloading the Hulu app, we recommend updating to the most current version of iOS.